24
Apr
10

Something different….


Now the engine is finished – I’m going to start posting artilces on events and cars in the Mopar scene. This will be a return to the “E-Zine” format, but with a more personal viewpoint and a tighter “focus” on topic.

————————————————–

A mate of mine paid a visit to my place in his new toy today – a beautiful 64 Dodge SS clone.

Pictures really do not do this car justice – it looks like it is out of a time capsule, and the attention to the period correct Ramcharger stuff is great.

The car has a mild 383 in it – hyd cam around .480 kift with around 280 adv . DP intake and 3.5 gears. Has run a best time of 13.4 at 105.

Its a push button manual, the lettering is hand painted on like the old days, and even has the correct block off plates etc…

The only significant difference between it and a genuine car is the 383 and the bonnet is a Polara hood with chrome trim.

I couldn’t get over how smoothly it runs and idles. Its also a 50th Dodge anniversary model in Anniversy Gold making it one rare car!

Front wheel are 4″ wide TTs with Hurst cross plys, the rear are original Hurst Cheater slicks.

Enjoy the pics.!

Advertisements

9 Responses to “Something different….”


  1. 1 Andy
    April 25, 2010 at 4:38 pm

    Thanks guys,was gonna tweak it a little today,then take it for a spin,but its been raining here so will try again tomorrow,can make some observations in shed though.Cheers
    Andy

  2. 2 nqkjw aka sixpack
    April 25, 2010 at 11:53 am

    BTW,cool mate’s car Mal.
    Not my thing although I do greatly admire that sort of thing.
    A mate of mine up here has one up here very similar.
    383 Plymouth Belvedere with the daisy fronts and steel rears,etc

    • 3 Chris
      April 25, 2010 at 1:01 pm

      Great work Mal, there some good stuff in here. Good to see that someone in the circle actually makes the effort to revive, support and live the passion.

  3. 4 nqkjw aka sixpack
    April 25, 2010 at 11:49 am

    Hey Andy
    I’d say one or more of
    Cam timing
    Ignition timing
    Secondaries not working
    Serious exhaust restriction

    You want 38 deg total ignition timing.

    The engine that was in my 440 challenger sounds pretty much like yours.
    440+30 with 10:1 TRW slugs
    Std 452 heads
    Same cam as yours
    Holley 750vac on Edelbrock PerformerRPM
    HP exhaust manifolds into twin 2.5″ press bent with no balance tube
    HP mechanical fuel pump through 3/8″ line
    Chrysler electronic dizzy(bad curve)and mopar orange box
    Windage tray

    Ran best of 14.3@96 on street tyres shifting at 5500-5600
    Would valve float at 6400

    Hope this helps.
    Gives you a rough idea of where yours should be at

    Regards Ken

  4. April 25, 2010 at 9:46 am

    Pretty hard to diagnose a problem over the internet…but it sounds like retarded ignition timing.

    If the secondaries ar opening over the last 20 degrees of rotation of the iinkage and the air door is opening with no backfire, I can’t see it being a carb issue if the thing is just not revving.

    Also , fuel starvation will cause it to fall on its face and pick up again as soon as you lift your foot…so if its not doing that then its proabbly not fuel supply.

  5. 6 James
    April 25, 2010 at 9:01 am

    Hey guys – good to see you back Mal, and yep, sweet dodge. Andy, check your secondaries are opening. I drove around for ages with my 360, with 484 cam and Thermoquad on the primaries only (not knowing) thinking it only needs a tune. Then I realised the little catch wasn’t engaging the rod that opens the secondaries. I wired it down, so it always caught the rod, and wow – different car!. Check it out, hope yours is as easy fix as mine was. Cheers, James.

  6. 7 Andy
    April 25, 2010 at 8:55 am

    I’ll check it out,I’m just running a mopar elec dizzy & orange box with Mallory coil,carb was built by Andrew Gadd,may have to recurve the dizzy,have checked carb secondaries with engine off,they open but needs to be WOT for this to happen,theyre pretty much open fully or not at all.I’m guessing thats normal for a TQ.hope to have a play today.Its still got more grunt than my mates 383 SS camaro off the lights!
    Andy

  7. April 25, 2010 at 12:28 am

    Hi Andy

    2.5″ I believe.

    3500 seems very low to be flatlining – At worst I’d be looking at the cam and making sure it’s installed properly. Also your ECU, ignition advance and carb tuning – are your secondarys opening ok?

  8. 9 Andy
    April 24, 2010 at 10:48 pm

    Hey Mal,good to see the website up & running again.That dodge looks great,sounds like it runs well too,what type of exhaust is he running,dual 3″do you know?I have a 440 in my Challenger with a mopar 484 purple shaft,(the one I got you to bring in for me),it runs nice with thermoquad & twin 2″ exhaust,but seems to run out of puff at around 3500rpm.I have a 3″mandrel tti system coming hoping it will make a difference,may have to swap to dbl pumper carb’.Whadya reckon.
    Cheers
    Andy


Leave a comment -

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 131 other followers

Blog Stats

  • 12,169 hits

%d bloggers like this: